AstroImager 4.x

Bug fixes and minor version announcement.
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

Fixed + one more change in sequencer (cancel/save/start buttons):

http://download.cloudmakers.eu/AstroImager_4.0_539.dmg
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

New agent with automatic star detection (= if focusing is started without selected star, one is selected automatically), sequencer can park the mount now (mount agent needs to be selected).

http://download.cloudmakers.eu/AstroImager_4.0_540.dmg

Screenshot 2020-09-10 at 09.09.23.jpg
Screenshot 2020-09-10 at 09.09.23.jpg (908.59 KiB) Viewed 174 times
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

INIDGO updated, star detection improved, parallel use of v3.x and v4.0 fixed:

http://download.cloudmakers.eu/AstroImager_4.0_541.dmg
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

New dithering control between AI/AD and AG.

Dithering doesn't work with previous version of INDIGO agents, so don't try with INDIGO Sky until it will be updated too.

http://download.cloudmakers.eu/AstroImager_4.0_542.dmg

Screenshot 2020-09-21 at 09.25.26.png
Screenshot 2020-09-21 at 09.25.26.png (816.07 KiB) Viewed 145 times
ThatsMyCoffee
Posts: 73
Joined: Tue Jul 09, 2019 4:59 pm

Re: AstroImager 4.x

Post by ThatsMyCoffee »

Getting an error with v4, "bad_file_descripti?" when an image is completed and should be saved. The file is NOT saved, but the series will continue and in the end there no data at all, since each file gets the same error.

I've been naming the files crazy things like "lights", "darks" and so on. When I leave the files with the default "IMG" setting, they are saved correctly.

Is this a bug? or can we not really assign any name we like in the "Name" field?
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

It should be possible to use any name (you just can't use some characters like '/' or ':'), maybe it was related to the folder, not the file name.

BTW in Preferences you have a lot of checkboxes "Encode XY into image file name", you can encode frame type (light/dark/etc) automatically.
ThatsMyCoffee
Posts: 73
Joined: Tue Jul 09, 2019 4:59 pm

Re: AstroImager 4.x

Post by ThatsMyCoffee »

Sorry, but neither of those are the case here. I am not using special characters and it will save to these same folders after I change the name. If AI can't handle the name I input (whatever the reason), it should *at least* save the file and change the name to some default, right? The loss of data is very not good. I don't always see the error message and have done entire image runs with complete data loss. The "bad file descriptor" message is not sufficient.


Some other random product improvement ideas:

-Dropdown menus for Gain & offset
-User changeable values for those dropdowns
-Bonus points for tying the offset to the gain, so it never needs to be adjusted.
-OR a set of 3 simple pushbuttons: Zero gain / Unity gain / High Gain (linked to offset)

In a typical imaging night, I'm focusing and imaging at 2 different values and switching between them frequently. A dozen times a night or more? Since I can't seem to type in the value I want directly, I'm using the up/down arrows a LOT and it's annoying/time consuming. Can anything be done?

Thanks for listening to us Peter. We appreciate your constant improvements to these products.
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

Well, any valid name should work, there is really no reason why "IMG" should work and "light" shouldn't :(

To try another name automatically is not as easy as it seems, uniform handling of name patterns for image download in all 3 cases (local agent with local driver, local agent with remote driver, remote driver) with numbering replacement is bloody complicated even as it is. We need to find out what's wrong with the name.

Another problem is, that the message "bad file descriptor" is a message from underlying operating system call and is quite suspicious, because it probably means, that creation of the file succeeded, but writing to it failed. Can you reproduce the issue and if you can, pls. can you make a trace log?
-Dropdown menus for Gain & offset
-User changeable values for those dropdowns
A good idea.
-Bonus points for tying the offset to the gain, so it never needs to be adjusted.
-OR a set of 3 simple pushbuttons: Zero gain / Unity gain / High Gain (linked to offset)
Well this can be considered, but without some standardisation on server side this will make AstroImager ASI specific software and it is not what we want to do (unity gain is available for ASI and Atik Horizon only and works a bit differently). I'll look at it. Maybe better solution is to add some "user configurable" buttons and fields to the toolbar bound to devices specific properties....

Peter
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

INDIGO bug fixes in QHY, AltairAstro and Touptek drivers:

http://download.cloudmakers.eu/AstroImager_4.0_543.dmg
User avatar
Peter Polakovic
Posts: 1993
Joined: Thu Apr 21, 2016 9:38 am

Re: AstroImager 4.x

Post by Peter Polakovic »

Post Reply