Autofocus with Nikon D5100: "No RAW image received"

Questions, bug reports, requests for enhancements, etc.
Post Reply
DavidTrumble
Posts: 3
Joined: Thu Jun 11, 2020 8:06 am

Autofocus with Nikon D5100: "No RAW image received"

Post by DavidTrumble »

Hi,

I'm trying to use autofocus with my D5100 using the latest version of AstroDSLR,.

I can manually focus the lens with focus in or focus out buttons, but autofocus gives me:

22:39:09.093 INDIGO Started...
22:39:09.095 AstroDSLR 4.0_603 INDIGO 2.0_149 OS 11.4_0 HW MacBookAir8,2/x86_64, GPU not used
22:39:09.198 Executing on-load scripts
22:39:17.523 'Nikon D5100 #140204' selected
22:39:23.975 'Nikon D5100 (focuser) #140204' selected
22:41:04.626 Focusing started
22:41:12.507 No RAW image received
22:41:12.508 Focusing failed

Am I missing something?

Thanks!
Dave
User avatar
Peter Polakovic
Posts: 2696
Joined: Thu Apr 21, 2016 9:38 am

Re: Autofocus with Nikon D5100: "No RAW image received"

Post by Peter Polakovic »

Hi Dave, it looks that for some reason conversion from JPEG to INDIGO RAW failed. Pls. make sure you set some of JPEG modes before trying autofocus. It will not work with NIKON RAW mode, because it is not so easy to convert it to INDIGO RAW needed for imager agent.

If this is not the case, pls. can you make a trace log?

https://bb.cloudmakers.eu/viewtopic.php?f=5&t=632
DavidTrumble
Posts: 3
Joined: Thu Jun 11, 2020 8:06 am

Re: Autofocus with Nikon D5100: "No RAW image received"

Post by DavidTrumble »

Update:

Played with it a bit more last night.

When I changed the format from "Raw+JPEG" to just "JPEG", the autofocusing started working.

It ran for a few minutes, but since it was mostly cloudy, I never saw the autofocus succeed.

Baby steps ... (no pun intended)
User avatar
Peter Polakovic
Posts: 2696
Joined: Thu Apr 21, 2016 9:38 am

Re: Autofocus with Nikon D5100: "No RAW image received"

Post by Peter Polakovic »

Yep, that it is. INDIGO autofocus routine works only with INDIGO RAW images. DSLR driver can produce them by converting from JPEG images, but not from NIKON RAW images. If RAW & JPEG mode is selected, RAW is used as main frame and JPEG as preview frame only. So it is kind of "feature" of INDIGO imager agent.
ThatsMyCoffee
Posts: 103
Joined: Tue Jul 09, 2019 4:59 pm

Re: Autofocus with Nikon D5100: "No RAW image received"

Post by ThatsMyCoffee »

re: D5100

Autofocus will probably never work in the dark. At least it didn't for my camera, no matter what lens or target I tried.

The best I could do is to zoom in on a star and manually focus with really small steps.
User avatar
Peter Polakovic
Posts: 2696
Joined: Thu Apr 21, 2016 9:38 am

Re: Autofocus with Nikon D5100: "No RAW image received"

Post by Peter Polakovic »

V4.0 uses regular exposures so it may work, if there is bright enough star in the field. But bahtinov mask is generally a better choice.
Post Reply