Autofocus seems suspect

Questions, bug reports, requests for enhancements, etc.
iMustBcrazy
Posts: 338
Joined: Sun Jun 02, 2019 3:52 pm

Re: Autofocus seems suspect

Post by iMustBcrazy »

Hi @rumen,

I got a failed "make all". What should I do? Do you want me to message you via github account? Here is tail of the console output:

indigo_server -------------------------

rm -f *.o /home/pi/indigo/build/bin/indigo_server *.data resource/*.data
make[2]: Leaving directory '/home/pi/indigo/indigo_server'
make[2]: Entering directory '/home/pi/indigo/indigo_tools'

indigo_tools -------------------------

rm -f *.o /home/pi/indigo/build/bin/indigo_prop_tool /home/pi/indigo/build/bin/indigo_drivers
make[2]: Leaving directory '/home/pi/indigo/indigo_tools'
make[1]: Leaving directory '/home/pi/indigo'
make[1]: Entering directory '/home/pi/indigo/indigo_libs'

indigo_libs -------------------------

libusb-1.0:
libhidapi: /home/pi/indigo/build/lib/libhidapi-hidraw.a

cp indigo/indigo_config.h indigo/indigo_config.h.orig
sed 's/INDIGO_BUILD.*/INDIGO_BUILD "157"/' indigo/indigo_config.h.orig >indigo/indigo_config.h
export CC=gcc; export CXX=gcc; export CFLAGS="-g -fPIC -O3 -march=armv6 -mfpu=vfp -mfloat-abi=hard -marm -mthumb-interwork -I/home/pi/indigo/indigo_libs -I/home/pi/indigo/indigo_drivers -I/home/pi/indigo/indigo_linux_drivers -I/home/pi/indigo/build/include -std=gnu11 -pthread -DINDIGO_LINUX -DRPI_MANAGEMENT -D_FILE_OFFSET_BITS=64"; export CXXFLAGS="-g -fPIC -O3 -march=armv6 -mfpu=vfp -mfloat-abi=hard -marm -mthumb-interwork -I/home/pi/indigo/indigo_libs -I/home/pi/indigo/indigo_drivers -I/home/pi/indigo/indigo_linux_drivers -I/home/pi/indigo/build/include -std=gnu++11 -pthread -DINDIGO_LINUX"; export LDFLAGS="-lm -lrt -lusb-1.0 -pthread -L/home/pi/indigo/build/lib -Wl,-rpath=\$ORIGIN/../lib,-rpath=\$ORIGIN/../drivers,-rpath=. -lusb-1.0"; cd externals/hidapi; autoreconf -fiv; ./configure --prefix=/home/pi/indigo/build --libdir=/home/pi/indigo/build/lib --enable-shared=no --enable-static=yes CFLAGS="-g -fPIC -O3 -march=armv6 -mfpu=vfp -mfloat-abi=hard -marm -mthumb-interwork -I/home/pi/indigo/indigo_libs -I/home/pi/indigo/indigo_drivers -I/home/pi/indigo/indigo_linux_drivers -I/home/pi/indigo/build/include -std=gnu11 -pthread -DINDIGO_LINUX -DRPI_MANAGEMENT -D_FILE_OFFSET_BITS=64" --with-pic; make; make install
/bin/sh: 1: autoreconf: not found
/bin/sh: 1: ./configure: not found
make[2]: Entering directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[2]: *** No targets specified and no makefile found. Stop.
make[2]: Leaving directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[2]: Entering directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[2]: *** No rule to make target 'install'. Stop.
make[2]: Leaving directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[1]: *** [Makefile:161: /home/pi/indigo/build/lib/libhidapi-hidraw.a] Error 2
make[1]: Leaving directory '/home/pi/indigo/indigo_libs'
make: *** [Makefile:147: all] Error 2
pi@raspberrypi:~/indigo $
iMustBcrazy
Posts: 338
Joined: Sun Jun 02, 2019 3:52 pm

Re: Autofocus seems suspect

Post by iMustBcrazy »

Got a little further by reinstalling autoconf... now have hidapi error...


indigo_libs -------------------------

libusb-1.0:
libhidapi: /home/pi/indigo/build/lib/libhidapi-hidraw.a

cp indigo/indigo_config.h indigo/indigo_config.h.orig
sed 's/INDIGO_BUILD.*/INDIGO_BUILD "157"/' indigo/indigo_config.h.orig >indigo/indigo_config.h
export CC=gcc; export CXX=gcc; export CFLAGS="-g -fPIC -O3 -march=armv6 -mfpu=vfp -mfloat-abi=hard -marm -mthumb-interwork -I/home/pi/indigo/indigo_libs -I/home/pi/indigo/indigo_drivers -I/home/pi/indigo/indigo_linux_drivers -I/home/pi/indigo/build/include -std=gnu11 -pthread -DINDIGO_LINUX -DRPI_MANAGEMENT -D_FILE_OFFSET_BITS=64"; export CXXFLAGS="-g -fPIC -O3 -march=armv6 -mfpu=vfp -mfloat-abi=hard -marm -mthumb-interwork -I/home/pi/indigo/indigo_libs -I/home/pi/indigo/indigo_drivers -I/home/pi/indigo/indigo_linux_drivers -I/home/pi/indigo/build/include -std=gnu++11 -pthread -DINDIGO_LINUX"; export LDFLAGS="-lm -lrt -lusb-1.0 -pthread -L/home/pi/indigo/build/lib -Wl,-rpath=\$ORIGIN/../lib,-rpath=\$ORIGIN/../drivers,-rpath=. -lusb-1.0"; cd externals/hidapi; autoreconf -fiv; ./configure --prefix=/home/pi/indigo/build --libdir=/home/pi/indigo/build/lib --enable-shared=no --enable-static=yes CFLAGS="-g -fPIC -O3 -march=armv6 -mfpu=vfp -mfloat-abi=hard -marm -mthumb-interwork -I/home/pi/indigo/indigo_libs -I/home/pi/indigo/indigo_drivers -I/home/pi/indigo/indigo_linux_drivers -I/home/pi/indigo/build/include -std=gnu11 -pthread -DINDIGO_LINUX -DRPI_MANAGEMENT -D_FILE_OFFSET_BITS=64" --with-pic; make; make install
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
configure.ac:25: installing './ar-lib'
configure.ac:25: installing './compile'
configure.ac:143: installing './config.guess'
configure.ac:143: installing './config.sub'
configure.ac:22: installing './install-sh'
configure.ac:22: installing './missing'
hidtest/Makefile.am: installing './depcomp'
libusb/Makefile.am:11: error: Libtool library used but 'LIBTOOL' is undefined
libusb/Makefile.am:11: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
libusb/Makefile.am:11: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
libusb/Makefile.am:11: If 'LT_INIT' is in 'configure.ac', make sure
libusb/Makefile.am:11: its definition is in aclocal's search path.
libusb/Makefile.am:18: error: Libtool library used but 'LIBTOOL' is undefined
libusb/Makefile.am:18: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
libusb/Makefile.am:18: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
libusb/Makefile.am:18: If 'LT_INIT' is in 'configure.ac', make sure
libusb/Makefile.am:18: its definition is in aclocal's search path.
libusb/Makefile.am:4: error: Libtool library used but 'LIBTOOL' is undefined
libusb/Makefile.am:4: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
libusb/Makefile.am:4: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
libusb/Makefile.am:4: If 'LT_INIT' is in 'configure.ac', make sure
libusb/Makefile.am:4: its definition is in aclocal's search path.
linux/Makefile.am:1: error: Libtool library used but 'LIBTOOL' is undefined
linux/Makefile.am:1: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
linux/Makefile.am:1: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
linux/Makefile.am:1: If 'LT_INIT' is in 'configure.ac', make sure
linux/Makefile.am:1: its definition is in aclocal's search path.
mac/Makefile.am:1: error: Libtool library used but 'LIBTOOL' is undefined
mac/Makefile.am:1: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
mac/Makefile.am:1: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
mac/Makefile.am:1: If 'LT_INIT' is in 'configure.ac', make sure
mac/Makefile.am:1: its definition is in aclocal's search path.
windows/Makefile.am:1: error: Libtool library used but 'LIBTOOL' is undefined
windows/Makefile.am:1: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
windows/Makefile.am:1: to 'configure.ac' and run 'aclocal' and 'autoconf' again.
windows/Makefile.am:1: If 'LT_INIT' is in 'configure.ac', make sure
windows/Makefile.am:1: its definition is in aclocal's search path.
autoreconf: automake failed with exit status: 1
configure: WARNING: unrecognized options: --enable-shared, --enable-static, --with-pic
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports the include directive... yes (GNU style)
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/home/pi/indigo/indigo_libs/externals/hidapi':
configure: error: C compiler cannot create executables
See `config.log' for more details
make[2]: Entering directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[2]: *** No targets specified and no makefile found. Stop.
make[2]: Leaving directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[2]: Entering directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[2]: *** No rule to make target 'install'. Stop.
make[2]: Leaving directory '/home/pi/indigo/indigo_libs/externals/hidapi'
make[1]: *** [Makefile:161: /home/pi/indigo/build/lib/libhidapi-hidraw.a] Error 2
make[1]: Leaving directory '/home/pi/indigo/indigo_libs'
make: *** [Makefile:147: all] Error 2
pi@raspberrypi:~/indigo $
iMustBcrazy
Posts: 338
Joined: Sun Jun 02, 2019 3:52 pm

Re: Autofocus seems suspect

Post by iMustBcrazy »

I think its ok now. updated my pi and reran installs. compiling now :)
iMustBcrazy
Posts: 338
Joined: Sun Jun 02, 2019 3:52 pm

Re: Autofocus seems suspect

Post by iMustBcrazy »

Success!

But I need to create a deb package to copy to my indigosky pi. Seems I need a DEBIAN/control file, which I can't find.
rumen
Posts: 133
Joined: Wed Feb 22, 2017 7:31 pm

Re: Autofocus seems suspect

Post by rumen »

try
make package

:)
rumen
Posts: 133
Joined: Wed Feb 22, 2017 7:31 pm

Re: Autofocus seems suspect

Post by rumen »

What comes to doube aplication yes it was applied twise. Once the device itself once the agent. Device will not report new position with the backlash applied that is why you see it once:)
iMustBcrazy
Posts: 338
Joined: Sun Jun 02, 2019 3:52 pm

Re: Autofocus seems suspect

Post by iMustBcrazy »

rumen wrote: Wed Aug 04, 2021 5:57 pm try
make package

:)
Lol! - that worked

So all set. I can try this tonight. Hopefully the weather will cooperate - have to contend with forest fire smoke now!
rumen
Posts: 133
Joined: Wed Feb 22, 2017 7:31 pm

Re: Autofocus seems suspect

Post by rumen »

Forest fires... A bad thing, we have several of them in our country. One school and 10+ houses burned down despite all the helicopters and all the machinery trying to stop them. But I think it is worse in turkey and Greece.
iMustBcrazy
Posts: 338
Joined: Sun Jun 02, 2019 3:52 pm

Re: Autofocus seems suspect

Post by iMustBcrazy »

rumen wrote: Wed Aug 04, 2021 7:14 pm Forest fires... A bad thing, we have several of them in our country. One school and 10+ houses burned down despite all the helicopters and all the machinery trying to stop them. But I think it is worse in turkey and Greece.
Yeah it seems global warming is upon us all. No hiding from it.
rumen
Posts: 133
Joined: Wed Feb 22, 2017 7:31 pm

Re: Autofocus seems suspect

Post by rumen »

Did you manage to test AF?
Post Reply